summaryrefslogtreecommitdiffstats
path: root/third_party/rust/debugid/scripts/bump-version.sh
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/debugid/scripts/bump-version.sh')
-rwxr-xr-xthird_party/rust/debugid/scripts/bump-version.sh17
1 files changed, 17 insertions, 0 deletions
diff --git a/third_party/rust/debugid/scripts/bump-version.sh b/third_party/rust/debugid/scripts/bump-version.sh
new file mode 100755
index 0000000000..41e67772d9
--- /dev/null
+++ b/third_party/rust/debugid/scripts/bump-version.sh
@@ -0,0 +1,17 @@
+#!/bin/bash
+set -euo pipefail
+
+if [ "$(uname -s)" != "Linux" ]; then
+ echo "Please use the GitHub Action."
+ exit 1
+fi
+
+SCRIPT_DIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
+cd $SCRIPT_DIR/..
+
+OLD_VERSION="${1}"
+NEW_VERSION="${2}"
+
+echo "Bumping version: ${NEW_VERSION}"
+
+find . -name Cargo.toml -type f -exec sed -i '' -e "s/^version.*/version = \"$NEW_VERSION\"/" {} \;