summaryrefslogtreecommitdiffstats
path: root/third_party/rust/error-support-macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/error-support-macros/Cargo.toml')
-rw-r--r--third_party/rust/error-support-macros/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/third_party/rust/error-support-macros/Cargo.toml b/third_party/rust/error-support-macros/Cargo.toml
new file mode 100644
index 0000000000..bf2f8053f6
--- /dev/null
+++ b/third_party/rust/error-support-macros/Cargo.toml
@@ -0,0 +1,32 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "error-support-macros"
+version = "0.1.0"
+publish = false
+license = "MPL-2.0"
+
+[lib]
+proc-macro = true
+
+[dependencies]
+proc-macro2 = "1.0"
+quote = "1.0"
+
+[dependencies.syn]
+version = "1.0"
+features = [
+ "derive",
+ "parsing",
+ "full",
+]