summaryrefslogtreecommitdiffstats
path: root/third_party/rust/gl_generator/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/gl_generator/Cargo.toml')
-rw-r--r--third_party/rust/gl_generator/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/gl_generator/Cargo.toml b/third_party/rust/gl_generator/Cargo.toml
new file mode 100644
index 0000000000..88c6a85a9b
--- /dev/null
+++ b/third_party/rust/gl_generator/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "gl_generator"
+version = "0.14.0"
+authors = ["Brendan Zabarauskas <bjzaba@yahoo.com.au>", "Corey Richardson", "Arseny Kapoulkine"]
+description = "Code generators for creating bindings to the Khronos OpenGL APIs."
+homepage = "https://github.com/brendanzab/gl-rs/"
+documentation = "https://docs.rs/gl_generator"
+readme = "README.md"
+keywords = ["gl", "egl", "opengl", "khronos"]
+categories = ["api-bindings", "rendering::graphics-api"]
+license = "Apache-2.0"
+repository = "https://github.com/brendanzab/gl-rs/"
+
+[lib]
+name = "gl_generator"
+path = "lib.rs"
+[dependencies.khronos_api]
+version = "3.1.0"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.xml-rs]
+version = "0.8"
+
+[features]
+unstable_generator_utils = []