summaryrefslogtreecommitdiffstats
path: root/third_party/rust/glob/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/glob/README.md')
-rw-r--r--third_party/rust/glob/README.md38
1 files changed, 38 insertions, 0 deletions
diff --git a/third_party/rust/glob/README.md b/third_party/rust/glob/README.md
new file mode 100644
index 0000000000..b68a40e402
--- /dev/null
+++ b/third_party/rust/glob/README.md
@@ -0,0 +1,38 @@
+glob
+====
+
+Support for matching file paths against Unix shell style patterns.
+
+[![Continuous integration](https://github.com/rust-lang/glob/actions/workflows/rust.yml/badge.svg)](https://github.com/rust-lang/glob/actions/workflows/rust.yml)
+
+[Documentation](https://docs.rs/glob)
+
+## Usage
+
+To use `glob`, add this to your `Cargo.toml`:
+
+```toml
+[dependencies]
+glob = "0.3.1"
+```
+
+And add this to your crate root:
+
+```rust
+extern crate glob;
+```
+
+## Examples
+
+Print all jpg files in /media/ and all of its subdirectories.
+
+```rust
+use glob::glob;
+
+for entry in glob("/media/**/*.jpg").expect("Failed to read glob pattern") {
+ match entry {
+ Ok(path) => println!("{:?}", path.display()),
+ Err(e) => println!("{:?}", e),
+ }
+}
+```