summaryrefslogtreecommitdiffstats
path: root/third_party/rust/inherent/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/inherent/Cargo.toml')
-rw-r--r--third_party/rust/inherent/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/third_party/rust/inherent/Cargo.toml b/third_party/rust/inherent/Cargo.toml
new file mode 100644
index 0000000000..df15969a8a
--- /dev/null
+++ b/third_party/rust/inherent/Cargo.toml
@@ -0,0 +1,49 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.31"
+name = "inherent"
+version = "1.0.4"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+description = "Make trait methods callable without the trait in scope"
+documentation = "https://docs.rs/inherent"
+readme = "README.md"
+categories = [
+ "rust-patterns",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/inherent"
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1.0"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.syn]
+version = "1.0.75"
+features = ["full"]
+
+[dev-dependencies.rustversion]
+version = "1.0"
+
+[dev-dependencies.trybuild]
+version = "1.0.49"
+features = ["diff"]