summaryrefslogtreecommitdiffstats
path: root/third_party/rust/mapped_hyph/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/mapped_hyph/Cargo.toml')
-rw-r--r--third_party/rust/mapped_hyph/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/third_party/rust/mapped_hyph/Cargo.toml b/third_party/rust/mapped_hyph/Cargo.toml
new file mode 100644
index 0000000000..d1104c1c3a
--- /dev/null
+++ b/third_party/rust/mapped_hyph/Cargo.toml
@@ -0,0 +1,33 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "mapped_hyph"
+version = "0.4.3"
+authors = ["Jonathan Kew <jfkthame@gmail.com>"]
+description = "Hyphenation using precompiled memory-mapped tables"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+
+[[bench]]
+name = "bench"
+harness = false
+
+[dependencies]
+arrayref = "0.3.5"
+log = "0.4"
+
+[dependencies.memmap2]
+version = ">=0.2,<=0.5"
+
+[dev-dependencies]
+criterion = "0.3"