summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-crypto/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/neqo-crypto/Cargo.toml')
-rw-r--r--third_party/rust/neqo-crypto/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/third_party/rust/neqo-crypto/Cargo.toml b/third_party/rust/neqo-crypto/Cargo.toml
new file mode 100644
index 0000000000..d37b7de0c8
--- /dev/null
+++ b/third_party/rust/neqo-crypto/Cargo.toml
@@ -0,0 +1,49 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.57.0"
+name = "neqo-crypto"
+version = "0.6.4"
+authors = ["Martin Thomson <mt@lowentropy.net>"]
+build = "build.rs"
+license = "MIT/Apache-2.0"
+
+[dependencies.log]
+version = "0.4.0"
+default-features = false
+
+[dependencies.neqo-common]
+path = "../neqo-common"
+
+[dev-dependencies.test-fixture]
+path = "../test-fixture"
+
+[build-dependencies]
+serde = "1.0"
+serde_derive = "1.0"
+toml = "0.5"
+
+[build-dependencies.bindgen]
+version = "0.63"
+features = ["runtime"]
+default-features = false
+
+[build-dependencies.mozbuild]
+version = "0.1"
+optional = true
+
+[features]
+default = ["deny-warnings"]
+deny-warnings = []
+fuzzing = []
+gecko = ["mozbuild"]