summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ntapi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/ntapi/Cargo.toml')
-rw-r--r--third_party/rust/ntapi/Cargo.toml69
1 files changed, 69 insertions, 0 deletions
diff --git a/third_party/rust/ntapi/Cargo.toml b/third_party/rust/ntapi/Cargo.toml
new file mode 100644
index 0000000000..9106023086
--- /dev/null
+++ b/third_party/rust/ntapi/Cargo.toml
@@ -0,0 +1,69 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "ntapi"
+version = "0.4.0"
+authors = ["MSxDOS <melcodos@gmail.com>"]
+include = [
+ "src/**/*",
+ "Cargo.toml",
+ "build.rs",
+ "README.md",
+ "LICENSE-APACHE",
+ "LICENSE-MIT",
+]
+description = "FFI bindings for Native API"
+documentation = "https://docs.rs/ntapi/*/x86_64-pc-windows-msvc/ntapi/"
+readme = "README.md"
+keywords = [
+ "windows",
+ "ffi",
+ "ntapi",
+ "native",
+ "win32",
+]
+categories = [
+ "external-ffi-bindings",
+ "no-std",
+ "os::windows-apis",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/MSxDOS/ntapi"
+
+[package.metadata.docs.rs]
+default-target = "x86_64-pc-windows-msvc"
+targets = [
+ "aarch64-pc-windows-msvc",
+ "i686-pc-windows-msvc",
+ "x86_64-pc-windows-msvc",
+]
+
+[dependencies.winapi]
+version = "0.3.9"
+features = [
+ "cfg",
+ "evntrace",
+ "in6addr",
+ "inaddr",
+ "minwinbase",
+ "ntsecapi",
+ "windef",
+ "winioctl",
+]
+
+[features]
+default = ["user"]
+func-types = []
+impl-default = ["winapi/impl-default"]
+kernel = []
+user = []