summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ordered-float/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/ordered-float/Cargo.toml')
-rw-r--r--third_party/rust/ordered-float/Cargo.toml88
1 files changed, 88 insertions, 0 deletions
diff --git a/third_party/rust/ordered-float/Cargo.toml b/third_party/rust/ordered-float/Cargo.toml
new file mode 100644
index 0000000000..3849c270eb
--- /dev/null
+++ b/third_party/rust/ordered-float/Cargo.toml
@@ -0,0 +1,88 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "ordered-float"
+version = "3.4.0"
+authors = [
+ "Jonathan Reem <jonathan.reem@gmail.com>",
+ "Matt Brubeck <mbrubeck@limpet.net>",
+]
+description = "Wrappers for total ordering on floats"
+readme = "README.md"
+keywords = [
+ "no_std",
+ "ord",
+ "f64",
+ "f32",
+ "sort",
+]
+categories = [
+ "science",
+ "rust-patterns",
+ "no-std",
+]
+license = "MIT"
+repository = "https://github.com/reem/rust-ordered-float"
+
+[dependencies.arbitrary]
+version = "1.0.0"
+optional = true
+
+[dependencies.bytemuck]
+version = "1.12.2"
+optional = true
+default-features = false
+
+[dependencies.num-traits]
+version = "0.2.1"
+default-features = false
+
+[dependencies.proptest]
+version = "1.0.0"
+optional = true
+
+[dependencies.rand]
+version = "0.8.3"
+optional = true
+default-features = false
+
+[dependencies.rkyv]
+version = "0.7"
+features = ["size_32"]
+optional = true
+default-features = false
+
+[dependencies.schemars]
+version = "0.8.8"
+optional = true
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.speedy]
+version = "0.8.3"
+optional = true
+default-features = false
+
+[dev-dependencies.serde_test]
+version = "1.0"
+
+[features]
+default = ["std"]
+randtest = [
+ "rand/std",
+ "rand/std_rng",
+]
+std = ["num-traits/std"]