summaryrefslogtreecommitdiffstats
path: root/third_party/rust/prost/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/prost/Cargo.toml')
-rw-r--r--third_party/rust/prost/Cargo.toml60
1 files changed, 60 insertions, 0 deletions
diff --git a/third_party/rust/prost/Cargo.toml b/third_party/rust/prost/Cargo.toml
new file mode 100644
index 0000000000..c1112fdc20
--- /dev/null
+++ b/third_party/rust/prost/Cargo.toml
@@ -0,0 +1,60 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "prost"
+version = "0.8.0"
+authors = ["Dan Burkert <dan@danburkert.com>", "Tokio Contributors <team@tokio.rs>"]
+description = "A Protocol Buffers implementation for the Rust Language."
+documentation = "https://docs.rs/prost"
+readme = "README.md"
+keywords = ["protobuf", "serialization"]
+categories = ["encoding"]
+license = "Apache-2.0"
+repository = "https://github.com/tokio-rs/prost"
+[profile.bench]
+debug = true
+
+[lib]
+bench = false
+
+[[bench]]
+name = "varint"
+harness = false
+[dependencies.bytes]
+version = "1"
+default-features = false
+
+[dependencies.prost-derive]
+version = "0.8.0"
+optional = true
+[dev-dependencies.criterion]
+version = "0.3"
+
+[dev-dependencies.env_logger]
+version = "0.8"
+default-features = false
+
+[dev-dependencies.log]
+version = "0.4"
+
+[dev-dependencies.proptest]
+version = "1"
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[features]
+default = ["prost-derive", "std"]
+no-recursion-limit = []
+std = []