summaryrefslogtreecommitdiffstats
path: root/third_party/rust/qlog/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/qlog/Cargo.toml')
-rw-r--r--third_party/rust/qlog/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/third_party/rust/qlog/Cargo.toml b/third_party/rust/qlog/Cargo.toml
new file mode 100644
index 0000000000..a1304cd9ab
--- /dev/null
+++ b/third_party/rust/qlog/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "qlog"
+version = "0.4.0"
+authors = ["Lucas Pardue <lucaspardue.24.7@gmail.com>"]
+description = "qlog data model for QUIC and HTTP/3"
+readme = "README.md"
+keywords = ["qlog", "quic", "http3"]
+categories = ["network-programming"]
+license = "BSD-2-Clause"
+repository = "https://github.com/cloudflare/quiche"
+[dependencies.serde]
+version = "1"
+features = ["derive"]
+
+[dependencies.serde_derive]
+version = "1.0"
+
+[dependencies.serde_json]
+version = "1.0"
+features = ["preserve_order"]
+
+[dependencies.serde_with]
+version = "1.3.1"