summaryrefslogtreecommitdiffstats
path: root/third_party/rust/serde_with_macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/serde_with_macros/Cargo.toml')
-rw-r--r--third_party/rust/serde_with_macros/Cargo.toml62
1 files changed, 62 insertions, 0 deletions
diff --git a/third_party/rust/serde_with_macros/Cargo.toml b/third_party/rust/serde_with_macros/Cargo.toml
new file mode 100644
index 0000000000..f7bb663141
--- /dev/null
+++ b/third_party/rust/serde_with_macros/Cargo.toml
@@ -0,0 +1,62 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.46"
+name = "serde_with_macros"
+version = "1.5.2"
+authors = ["Jonas Bushart"]
+include = ["src/**/*", "LICENSE-*", "README.md", "CHANGELOG.md"]
+description = "proc-macro library for serde_with"
+documentation = "https://docs.rs/serde_with_macros/"
+readme = "README.md"
+keywords = ["serde", "utilities", "serialization", "deserialization"]
+categories = ["encoding"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/jonasbb/serde_with/"
+[package.metadata.docs.rs]
+all-features = true
+
+[lib]
+proc-macro = true
+[dependencies.darling]
+version = "0.13.4"
+
+[dependencies.proc-macro2]
+version = "1.0.1"
+
+[dependencies.quote]
+version = "1.0.0"
+
+[dependencies.syn]
+version = "1.0.3"
+features = ["full", "parsing"]
+[dev-dependencies.pretty_assertions]
+version = "1.0.0"
+
+[dev-dependencies.rustversion]
+version = "1.0.0"
+
+[dev-dependencies.serde]
+version = "1.0.75"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0.25"
+
+[dev-dependencies.trybuild]
+version = "1.0.14"
+
+[dev-dependencies.version-sync]
+version = "0.9.1"
+[badges.maintenance]
+status = "actively-developed"