summaryrefslogtreecommitdiffstats
path: root/third_party/rust/sync-guid/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/sync-guid/Cargo.toml')
-rw-r--r--third_party/rust/sync-guid/Cargo.toml46
1 files changed, 46 insertions, 0 deletions
diff --git a/third_party/rust/sync-guid/Cargo.toml b/third_party/rust/sync-guid/Cargo.toml
new file mode 100644
index 0000000000..8f142d7d87
--- /dev/null
+++ b/third_party/rust/sync-guid/Cargo.toml
@@ -0,0 +1,46 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "sync-guid"
+version = "0.1.0"
+authors = ["Thom Chiovoloni <tchiovoloni@mozilla.com>"]
+license = "MPL-2.0"
+
+[dependencies.base64]
+version = "0.13"
+optional = true
+
+[dependencies.rand]
+version = "0.8"
+optional = true
+
+[dependencies.rusqlite]
+version = "0.28.0"
+features = ["bundled"]
+optional = true
+
+[dependencies.serde]
+version = "1"
+optional = true
+
+[dev-dependencies]
+serde_test = "1"
+
+[features]
+default = ["serde_support"]
+random = [
+ "rand",
+ "base64",
+]
+rusqlite_support = ["rusqlite"]
+serde_support = ["serde"]