summaryrefslogtreecommitdiffstats
path: root/third_party/rust/terminal_size
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/terminal_size')
-rw-r--r--third_party/rust/terminal_size/.cargo-checksum.json1
-rw-r--r--third_party/rust/terminal_size/Cargo.lock39
-rw-r--r--third_party/rust/terminal_size/Cargo.toml27
-rw-r--r--third_party/rust/terminal_size/LICENSE-APACHE202
-rw-r--r--third_party/rust/terminal_size/LICENSE-MIT19
-rw-r--r--third_party/rust/terminal_size/README.md41
-rw-r--r--third_party/rust/terminal_size/examples/get_size.rs49
-rw-r--r--third_party/rust/terminal_size/src/lib.rs37
-rw-r--r--third_party/rust/terminal_size/src/unix.rs117
-rw-r--r--third_party/rust/terminal_size/src/windows.rs53
10 files changed, 585 insertions, 0 deletions
diff --git a/third_party/rust/terminal_size/.cargo-checksum.json b/third_party/rust/terminal_size/.cargo-checksum.json
new file mode 100644
index 0000000000..1f23934120
--- /dev/null
+++ b/third_party/rust/terminal_size/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.lock":"8d2028e8eb1b95d30a7809bf1aebfc474f13aee76f2a505fc7d9e32b97da9fe1","Cargo.toml":"26630191b28b81be8e6d692f032c8e8e62c4d4c977e7a4df1473d7477f39f02c","LICENSE-APACHE":"c6596eb7be8581c18be736c846fb9173b69eccf6ef94c5135893ec56bd92ba08","LICENSE-MIT":"bc8dcbbd559a61b8a8c0c89d5c3e15d0dc47c6fae94e78ac428d6a7b7da3c4f9","README.md":"d9b142c504cd57f8c93575baab35e4ec63520597adb1bbaedcc14840b3e8e63b","examples/get_size.rs":"11527a87b817e8e7f1c3920497920869e049660f6f89bb786f2758571c07c491","src/lib.rs":"2d43d3f8bee8ef9694bf1033b1a1522bce03485176ffd4d2f7e61e94ba2efe76","src/unix.rs":"0cbfff1bac23daea7432961d443cf788b50e2f03683b1bc75381595d72903e0b","src/windows.rs":"930729ab4cccd97f8e4932a10c6ade43dce43a5838d57a4ee6067f316e56e1d8"},"package":"633c1a546cee861a1a6d0dc69ebeca693bf4296661ba7852b9d21d159e0506df"} \ No newline at end of file
diff --git a/third_party/rust/terminal_size/Cargo.lock b/third_party/rust/terminal_size/Cargo.lock
new file mode 100644
index 0000000000..2665711e6b
--- /dev/null
+++ b/third_party/rust/terminal_size/Cargo.lock
@@ -0,0 +1,39 @@
+# This file is automatically @generated by Cargo.
+# It is not intended for manual editing.
+version = 3
+
+[[package]]
+name = "libc"
+version = "0.2.94"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "18794a8ad5b29321f790b55d93dfba91e125cb1a9edbd4f8e3150acc771c1a5e"
+
+[[package]]
+name = "terminal_size"
+version = "0.1.17"
+dependencies = [
+ "libc",
+ "winapi",
+]
+
+[[package]]
+name = "winapi"
+version = "0.3.9"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "5c839a674fcd7a98952e593242ea400abe93992746761e38641405d28b00f419"
+dependencies = [
+ "winapi-i686-pc-windows-gnu",
+ "winapi-x86_64-pc-windows-gnu",
+]
+
+[[package]]
+name = "winapi-i686-pc-windows-gnu"
+version = "0.4.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "ac3b87c63620426dd9b991e5ce0329eff545bccbbb34f3be09ff6fb6ab51b7b6"
+
+[[package]]
+name = "winapi-x86_64-pc-windows-gnu"
+version = "0.4.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f"
diff --git a/third_party/rust/terminal_size/Cargo.toml b/third_party/rust/terminal_size/Cargo.toml
new file mode 100644
index 0000000000..d8921879d5
--- /dev/null
+++ b/third_party/rust/terminal_size/Cargo.toml
@@ -0,0 +1,27 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "terminal_size"
+version = "0.1.17"
+authors = ["Andrew Chin <achin@eminence32.net>"]
+description = "Gets the size of your Linux or Windows terminal"
+documentation = "http://eminence.github.io/terminal-size/doc/terminal_size/index.html"
+keywords = ["terminal", "console", "term", "size", "dimensions"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/eminence/terminal-size"
+[target."cfg(not(windows))".dependencies.libc]
+version = "0.2"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["handleapi", "processenv", "winbase", "wincon", "winnt"]
diff --git a/third_party/rust/terminal_size/LICENSE-APACHE b/third_party/rust/terminal_size/LICENSE-APACHE
new file mode 100644
index 0000000000..8f71f43fee
--- /dev/null
+++ b/third_party/rust/terminal_size/LICENSE-APACHE
@@ -0,0 +1,202 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
+
+ APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "{}"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+ Copyright {yyyy} {name of copyright owner}
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+
diff --git a/third_party/rust/terminal_size/LICENSE-MIT b/third_party/rust/terminal_size/LICENSE-MIT
new file mode 100644
index 0000000000..a05bf276d1
--- /dev/null
+++ b/third_party/rust/terminal_size/LICENSE-MIT
@@ -0,0 +1,19 @@
+Copyright (c) 2015 The terminal-size Developers
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/third_party/rust/terminal_size/README.md b/third_party/rust/terminal_size/README.md
new file mode 100644
index 0000000000..bcaee60a36
--- /dev/null
+++ b/third_party/rust/terminal_size/README.md
@@ -0,0 +1,41 @@
+terminal-size
+=============
+
+
+[Documention](https://docs.rs/crate/terminal_size)
+
+
+Rust library to getting the size of your terminal.
+
+Works on Linux, MacOS, Windows, and illumos.
+
+```rust
+use terminal_size::{Width, Height, terminal_size};
+
+let size = terminal_size();
+if let Some((Width(w), Height(h))) = size {
+ println!("Your terminal is {} cols wide and {} lines tall", w, h);
+} else {
+ println!("Unable to get terminal size");
+}
+```
+
+## Minimum Rust Version
+
+This crate requires a minimum rust version of 1.31.0 (2018-12-06)
+
+## License
+
+Licensed under either of
+
+ * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally
+submitted for inclusion in the work by you, as defined in the Apache-2.0
+license, shall be dual licensed as above, without any additional terms or
+conditions.
diff --git a/third_party/rust/terminal_size/examples/get_size.rs b/third_party/rust/terminal_size/examples/get_size.rs
new file mode 100644
index 0000000000..155784d98e
--- /dev/null
+++ b/third_party/rust/terminal_size/examples/get_size.rs
@@ -0,0 +1,49 @@
+#[cfg(windows)]
+fn run() {
+ use std::os::windows::io::RawHandle;
+ use winapi::um::processenv::GetStdHandle;
+ use winapi::um::winbase::{STD_ERROR_HANDLE, STD_INPUT_HANDLE, STD_OUTPUT_HANDLE};
+
+ let stdout = unsafe { GetStdHandle(STD_OUTPUT_HANDLE) } as RawHandle;
+ println!(
+ "Size from terminal_size_using_handle(stdout): {:?}",
+ terminal_size::terminal_size_using_handle(stdout)
+ );
+
+ let stderr = unsafe { GetStdHandle(STD_ERROR_HANDLE) } as RawHandle;
+ println!(
+ "Size from terminal_size_using_handle(stderr): {:?}",
+ terminal_size::terminal_size_using_handle(stderr)
+ );
+
+ let stdin = unsafe { GetStdHandle(STD_INPUT_HANDLE) } as RawHandle;
+ println!(
+ "Size from terminal_size_using_handle(stdin): {:?}",
+ terminal_size::terminal_size_using_handle(stdin)
+ );
+}
+
+#[cfg(not(windows))]
+fn run() {
+ println!(
+ "Size from terminal_size_using_fd(stdout): {:?}",
+ terminal_size::terminal_size_using_fd(libc::STDOUT_FILENO)
+ );
+ println!(
+ "Size from terminal_size_using_fd(stderr): {:?}",
+ terminal_size::terminal_size_using_fd(libc::STDERR_FILENO)
+ );
+ println!(
+ "Size from terminal_size_using_fd(stdin): {:?}",
+ terminal_size::terminal_size_using_fd(libc::STDIN_FILENO)
+ );
+}
+
+fn main() {
+ println!(
+ "Size from terminal_size(): {:?}",
+ terminal_size::terminal_size()
+ );
+
+ run();
+}
diff --git a/third_party/rust/terminal_size/src/lib.rs b/third_party/rust/terminal_size/src/lib.rs
new file mode 100644
index 0000000000..6ef79be4a8
--- /dev/null
+++ b/third_party/rust/terminal_size/src/lib.rs
@@ -0,0 +1,37 @@
+//! A simple utility for getting the size of a terminal.
+//!
+//! Supports both Linux, MacOS, and Windows.
+//!
+//! This crate requires a minimum rust version of 1.31.0 (2018-12-06)
+//!
+//! # Example
+//!
+//! ```
+//! use terminal_size::{Width, Height, terminal_size};
+//!
+//! let size = terminal_size();
+//! if let Some((Width(w), Height(h))) = size {
+//! println!("Your terminal is {} cols wide and {} lines tall", w, h);
+//! } else {
+//! println!("Unable to get terminal size");
+//! }
+//! ```
+//!
+
+#[derive(Debug)]
+pub struct Width(pub u16);
+#[derive(Debug)]
+pub struct Height(pub u16);
+
+#[cfg(unix)]
+mod unix;
+#[cfg(unix)]
+pub use crate::unix::{terminal_size, terminal_size_using_fd};
+
+#[cfg(windows)]
+mod windows;
+#[cfg(windows)]
+pub use crate::windows::{terminal_size, terminal_size_using_handle};
+
+#[cfg(not(any(unix, windows)))]
+pub fn terminal_size() -> Option<(Width, Height)> { None }
diff --git a/third_party/rust/terminal_size/src/unix.rs b/third_party/rust/terminal_size/src/unix.rs
new file mode 100644
index 0000000000..59ac2768c8
--- /dev/null
+++ b/third_party/rust/terminal_size/src/unix.rs
@@ -0,0 +1,117 @@
+use super::{Height, Width};
+use std::os::unix::io::RawFd;
+
+/// Returns the size of the terminal defaulting to STDOUT, if available.
+///
+/// If STDOUT is not a tty, returns `None`
+pub fn terminal_size() -> Option<(Width, Height)> {
+ terminal_size_using_fd(libc::STDOUT_FILENO)
+}
+
+/// Returns the size of the terminal using the given file descriptor, if available.
+///
+/// If the given file descriptor is not a tty, returns `None`
+pub fn terminal_size_using_fd(fd: RawFd) -> Option<(Width, Height)> {
+ use libc::ioctl;
+ use libc::isatty;
+ use libc::{winsize as WinSize, TIOCGWINSZ};
+ let is_tty: bool = unsafe { isatty(fd) == 1 };
+
+ if !is_tty {
+ return None;
+ }
+
+ let mut winsize = WinSize {
+ ws_row: 0,
+ ws_col: 0,
+ ws_xpixel: 0,
+ ws_ypixel: 0,
+ };
+
+ if unsafe { ioctl(fd, TIOCGWINSZ.into(), &mut winsize) } == -1 {
+ return None;
+ }
+
+ let rows = winsize.ws_row;
+ let cols = winsize.ws_col;
+
+ if rows > 0 && cols > 0 {
+ Some((Width(cols), Height(rows)))
+ } else {
+ None
+ }
+}
+
+#[test]
+/// Compare with the output of `stty size`
+fn compare_with_stty() {
+ use std::process::Command;
+ use std::process::Stdio;
+
+ let (rows, cols) = if cfg!(target_os = "illumos") {
+ // illumos stty(1) does not accept a device argument, instead using
+ // stdin unconditionally:
+ let output = Command::new("stty")
+ .stdin(Stdio::inherit())
+ .output()
+ .unwrap();
+ assert!(output.status.success());
+
+ // stdout includes the row and columns thus: "rows = 80; columns = 24;"
+ let vals = String::from_utf8(output.stdout)
+ .unwrap()
+ .lines()
+ .map(|line| {
+ // Split each line on semicolons to get "k = v" strings:
+ line.split(';')
+ .map(str::trim)
+ .map(str::to_string)
+ .collect::<Vec<_>>()
+ })
+ .flatten()
+ .filter_map(|term| {
+ // split each "k = v" string and look for rows/columns:
+ match term.splitn(2, " = ").collect::<Vec<_>>().as_slice() {
+ ["rows", n] | ["columns", n] => Some(n.parse().unwrap()),
+ _ => None,
+ }
+ })
+ .collect::<Vec<_>>();
+ (vals[0], vals[1])
+ } else {
+ let output = if cfg!(target_os = "linux") {
+ Command::new("stty")
+ .arg("size")
+ .arg("-F")
+ .arg("/dev/stderr")
+ .stderr(Stdio::inherit())
+ .output()
+ .unwrap()
+ } else {
+ Command::new("stty")
+ .arg("-f")
+ .arg("/dev/stderr")
+ .arg("size")
+ .stderr(Stdio::inherit())
+ .output()
+ .unwrap()
+ };
+
+ assert!(output.status.success());
+ let stdout = String::from_utf8(output.stdout).unwrap();
+ // stdout is "rows cols"
+ let mut data = stdout.split_whitespace();
+ println!("{}", stdout);
+ let rows = u16::from_str_radix(data.next().unwrap(), 10).unwrap();
+ let cols = u16::from_str_radix(data.next().unwrap(), 10).unwrap();
+ (rows, cols)
+ };
+ println!("{} {}", rows, cols);
+
+ if let Some((Width(w), Height(h))) = terminal_size() {
+ assert_eq!(rows, h);
+ assert_eq!(cols, w);
+ } else {
+ panic!("terminal_size() return None");
+ }
+}
diff --git a/third_party/rust/terminal_size/src/windows.rs b/third_party/rust/terminal_size/src/windows.rs
new file mode 100644
index 0000000000..14f487f114
--- /dev/null
+++ b/third_party/rust/terminal_size/src/windows.rs
@@ -0,0 +1,53 @@
+use super::{Height, Width};
+use std::os::windows::io::RawHandle;
+
+/// Returns the size of the terminal defaulting to STDOUT, if available.
+///
+/// Note that this returns the size of the actual command window, and
+/// not the overall size of the command window buffer
+pub fn terminal_size() -> Option<(Width, Height)> {
+ use winapi::um::processenv::GetStdHandle;
+ use winapi::um::winbase::STD_OUTPUT_HANDLE;
+
+ let handle = unsafe { GetStdHandle(STD_OUTPUT_HANDLE) as RawHandle };
+
+ terminal_size_using_handle(handle)
+}
+
+/// Returns the size of the terminal using the given handle, if available.
+///
+/// If the given handle is not a tty, returns `None`
+pub fn terminal_size_using_handle(handle: RawHandle) -> Option<(Width, Height)> {
+ use winapi::um::handleapi::INVALID_HANDLE_VALUE;
+ use winapi::um::wincon::{
+ GetConsoleScreenBufferInfo, CONSOLE_SCREEN_BUFFER_INFO, COORD, SMALL_RECT,
+ };
+
+ // convert between winapi::um::winnt::HANDLE and std::os::windows::raw::HANDLE
+ let hand = handle as winapi::um::winnt::HANDLE;
+
+ if hand == INVALID_HANDLE_VALUE {
+ return None;
+ }
+
+ let zc = COORD { X: 0, Y: 0 };
+ let mut csbi = CONSOLE_SCREEN_BUFFER_INFO {
+ dwSize: zc,
+ dwCursorPosition: zc,
+ wAttributes: 0,
+ srWindow: SMALL_RECT {
+ Left: 0,
+ Top: 0,
+ Right: 0,
+ Bottom: 0,
+ },
+ dwMaximumWindowSize: zc,
+ };
+ if unsafe { GetConsoleScreenBufferInfo(hand, &mut csbi) } == 0 {
+ return None;
+ }
+
+ let w: Width = Width((csbi.srWindow.Right - csbi.srWindow.Left + 1) as u16);
+ let h: Height = Height((csbi.srWindow.Bottom - csbi.srWindow.Top + 1) as u16);
+ Some((w, h))
+}