summaryrefslogtreecommitdiffstats
path: root/third_party/rust/uniffi_build/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/uniffi_build/Cargo.toml')
-rw-r--r--third_party/rust/uniffi_build/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/uniffi_build/Cargo.toml b/third_party/rust/uniffi_build/Cargo.toml
new file mode 100644
index 0000000000..c7a0cced61
--- /dev/null
+++ b/third_party/rust/uniffi_build/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "uniffi_build"
+version = "0.23.0"
+authors = ["Firefox Sync Team <sync-team@mozilla.com>"]
+description = "a multi-language bindings generator for rust (build script helpers)"
+homepage = "https://mozilla.github.io/uniffi-rs"
+documentation = "https://mozilla.github.io/uniffi-rs"
+keywords = [
+ "ffi",
+ "bindgen",
+]
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/uniffi-rs"
+
+[dependencies.anyhow]
+version = "1"
+
+[dependencies.camino]
+version = "1.0.8"
+
+[dependencies.uniffi_bindgen]
+version = "=0.23.0"
+default-features = false
+
+[features]
+builtin-bindgen = []
+default = []