summaryrefslogtreecommitdiffstats
path: root/third_party/webkit/PerformanceTests/Speedometer/resources/todomvc/architecture-examples/react-redux/src/actions/index.spec.js
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/webkit/PerformanceTests/Speedometer/resources/todomvc/architecture-examples/react-redux/src/actions/index.spec.js')
-rw-r--r--third_party/webkit/PerformanceTests/Speedometer/resources/todomvc/architecture-examples/react-redux/src/actions/index.spec.js45
1 files changed, 45 insertions, 0 deletions
diff --git a/third_party/webkit/PerformanceTests/Speedometer/resources/todomvc/architecture-examples/react-redux/src/actions/index.spec.js b/third_party/webkit/PerformanceTests/Speedometer/resources/todomvc/architecture-examples/react-redux/src/actions/index.spec.js
new file mode 100644
index 0000000000..06c894c1a5
--- /dev/null
+++ b/third_party/webkit/PerformanceTests/Speedometer/resources/todomvc/architecture-examples/react-redux/src/actions/index.spec.js
@@ -0,0 +1,45 @@
+import * as types from '../constants/ActionTypes'
+import * as actions from './index'
+
+describe('todo actions', () => {
+ it('addTodo should create ADD_TODO action', () => {
+ expect(actions.addTodo('Use Redux')).toEqual({
+ type: types.ADD_TODO,
+ text: 'Use Redux'
+ })
+ })
+
+ it('deleteTodo should create DELETE_TODO action', () => {
+ expect(actions.deleteTodo(1)).toEqual({
+ type: types.DELETE_TODO,
+ id: 1
+ })
+ })
+
+ it('editTodo should create EDIT_TODO action', () => {
+ expect(actions.editTodo(1, 'Use Redux everywhere')).toEqual({
+ type: types.EDIT_TODO,
+ id: 1,
+ text: 'Use Redux everywhere'
+ })
+ })
+
+ it('completeTodo should create COMPLETE_TODO action', () => {
+ expect(actions.completeTodo(1)).toEqual({
+ type: types.COMPLETE_TODO,
+ id: 1
+ })
+ })
+
+ it('completeAll should create COMPLETE_ALL action', () => {
+ expect(actions.completeAll()).toEqual({
+ type: types.COMPLETE_ALL
+ })
+ })
+
+ it('clearCompleted should create CLEAR_COMPLETED action', () => {
+ expect(actions.clearCompleted()).toEqual({
+ type: types.CLEAR_COMPLETED
+ })
+ })
+})