summaryrefslogtreecommitdiffstats
path: root/toolkit/library/build/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/library/build/Makefile.in')
-rw-r--r--toolkit/library/build/Makefile.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/toolkit/library/build/Makefile.in b/toolkit/library/build/Makefile.in
new file mode 100644
index 0000000000..474c42518c
--- /dev/null
+++ b/toolkit/library/build/Makefile.in
@@ -0,0 +1,20 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this file,
+# You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/config.mk
+
+include $(topsrcdir)/config/rules.mk
+
+DUMP_SYMBOLS_FLAGS = --count-ctors
+
+ifdef CLANG_CL
+ifdef MOZ_PROFILE_USE
+ifeq (x86,$(CPU_ARCH))
+PGO_LDFLAGS += -ORDER:@$(topsrcdir)/build/win32/orderfile.txt
+endif
+ifeq (x86_64,$(CPU_ARCH))
+PGO_LDFLAGS += -ORDER:@$(topsrcdir)/build/win64/orderfile.txt
+endif
+endif
+endif