summaryrefslogtreecommitdiffstats
path: root/browser/components/sessionstore/test/browser_replace_load.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /browser/components/sessionstore/test/browser_replace_load.js
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'browser/components/sessionstore/test/browser_replace_load.js')
-rw-r--r--browser/components/sessionstore/test/browser_replace_load.js55
1 files changed, 55 insertions, 0 deletions
diff --git a/browser/components/sessionstore/test/browser_replace_load.js b/browser/components/sessionstore/test/browser_replace_load.js
new file mode 100644
index 0000000000..64df429b63
--- /dev/null
+++ b/browser/components/sessionstore/test/browser_replace_load.js
@@ -0,0 +1,55 @@
+"use strict";
+
+const STATE = {
+ entries: [{ url: "about:robots" }, { url: "about:mozilla" }],
+ selected: 2,
+};
+
+/**
+ * Bug 1100223. Calling browser.loadURI() while a tab is loading causes
+ * sessionstore to override the desired target URL. This test ensures that
+ * calling loadURI() on a pending tab causes the tab to no longer be marked
+ * as pending and correctly finish the instructed load while keeping the
+ * restored history around.
+ */
+add_task(async function() {
+ await testSwitchToTab("about:mozilla#fooobar", {
+ ignoreFragment: "whenComparingAndReplace",
+ });
+ await testSwitchToTab("about:mozilla?foo=bar", { replaceQueryString: true });
+});
+
+var testSwitchToTab = async function(url, options) {
+ // Create a background tab.
+ let tab = BrowserTestUtils.addTab(gBrowser, "about:blank");
+ let browser = tab.linkedBrowser;
+ await promiseBrowserLoaded(browser);
+
+ // The tab shouldn't be restored right away.
+ Services.prefs.setBoolPref("browser.sessionstore.restore_on_demand", true);
+
+ // Prepare the tab state.
+ let promise = promiseTabRestoring(tab);
+ ss.setTabState(tab, JSON.stringify(STATE));
+ ok(tab.hasAttribute("pending"), "tab is pending");
+ await promise;
+
+ options.triggeringPrincipal = Services.scriptSecurityManager.getSystemPrincipal();
+
+ // Switch-to-tab with a similar URI.
+ switchToTabHavingURI(url, false, options);
+
+ // Tab should now restore
+ await promiseTabRestored(tab);
+ is(browser.currentURI.spec, url, "correct URL loaded");
+
+ // Check that we didn't lose any history entries.
+ await SpecialPowers.spawn(browser, [], async function() {
+ let webNavigation = docShell.QueryInterface(Ci.nsIWebNavigation);
+ let history = webNavigation.sessionHistory;
+ Assert.equal(history && history.count, 3, "three history entries");
+ });
+
+ // Cleanup.
+ gBrowser.removeTab(tab);
+};