summaryrefslogtreecommitdiffstats
path: root/taskcluster/scripts/misc/wasi-sdk.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /taskcluster/scripts/misc/wasi-sdk.patch
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'taskcluster/scripts/misc/wasi-sdk.patch')
-rw-r--r--taskcluster/scripts/misc/wasi-sdk.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/taskcluster/scripts/misc/wasi-sdk.patch b/taskcluster/scripts/misc/wasi-sdk.patch
new file mode 100644
index 0000000000..40ee8f5f0d
--- /dev/null
+++ b/taskcluster/scripts/misc/wasi-sdk.patch
@@ -0,0 +1,25 @@
+Patch from https://github.com/WebAssembly/wasi-libc/pull/344
+and https://github.com/WebAssembly/wasi-libc/pull/379.
+
+diff --git a/src/wasi-libc/Makefile b/src/wasi-libc/Makefile
+index 44acdee..6e01bed 100644
+--- a/src/wasi-libc/Makefile
++++ b/src/wasi-libc/Makefile
+@@ -556,6 +556,8 @@ check-symbols: startup_files libc
+ -U__clang_version__ \
+ -U__clang_literal_encoding__ \
+ -U__clang_wide_literal_encoding__ \
++ -U__wasm_mutable_globals__ \
++ -U__wasm_sign_ext__ \
+ -U__GNUC__ \
+ -U__GNUC_MINOR__ \
+ -U__GNUC_PATCHLEVEL__ \
+@@ -565,6 +567,8 @@ check-symbols: startup_files libc
+ -U__BITINT_MAXWIDTH__ \
+ -U__FLT_EVAL_METHOD__ -Wno-builtin-macro-redefined \
+ | sed -e 's/__[[:upper:][:digit:]]*_ATOMIC_\([[:upper:][:digit:]_]*\)_LOCK_FREE/__compiler_ATOMIC_\1_LOCK_FREE/' \
++ | sed -e 's/__GNUC_VA_LIST $$/__GNUC_VA_LIST 1/' \
+ | grep -v '^#define __FLT16_' \
+ | grep -v '^#define __\(BOOL\|INT_\(LEAST\|FAST\)\(8\|16\|32\|64\)\|INT\|LONG\|LLONG\|SHRT\)_WIDTH__' \
++ | grep -v '^#define __GCC_HAVE_SYNC_COMPARE_AND_SWAP_\(1\|2\|4\|8\)' \
+ > "$(SYSROOT_SHARE)/predefined-macros.txt"