summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/console/console-label-conversion.any.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /testing/web-platform/tests/console/console-label-conversion.any.js
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/console/console-label-conversion.any.js')
-rw-r--r--testing/web-platform/tests/console/console-label-conversion.any.js29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/web-platform/tests/console/console-label-conversion.any.js b/testing/web-platform/tests/console/console-label-conversion.any.js
new file mode 100644
index 0000000000..4d48df3b1d
--- /dev/null
+++ b/testing/web-platform/tests/console/console-label-conversion.any.js
@@ -0,0 +1,29 @@
+"use strict";
+// https://console.spec.whatwg/org/#counting
+// https://console.spec.whatwg/org/#timing
+
+const methods = ['count', 'countReset', 'time', 'timeLog', 'timeEnd'];
+
+for (const method of methods) {
+ test(() => {
+ let labelToStringCalled = false;
+
+ console[method]({
+ toString() {
+ labelToStringCalled = true;
+ }
+ });
+
+ assert_true(labelToStringCalled, `${method}() must call toString() on label when label is an object`);
+ }, `console.${method}()'s label gets converted to string via label.toString() when label is an object`);
+
+ test(() => {
+ assert_throws_js(Error, () => {
+ console[method]({
+ toString() {
+ throw new Error('conversion error');
+ }
+ });
+ }, `${method} must re-throw any exceptions thrown by label.toString() conversion`);
+ }, `console.${method}() throws exceptions generated by erroneous label.toString() conversion`);
+}