summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/css-pseudo/highlight-styling-003.tentative.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /testing/web-platform/tests/css/css-pseudo/highlight-styling-003.tentative.html
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/css/css-pseudo/highlight-styling-003.tentative.html')
-rw-r--r--testing/web-platform/tests/css/css-pseudo/highlight-styling-003.tentative.html25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/css-pseudo/highlight-styling-003.tentative.html b/testing/web-platform/tests/css/css-pseudo/highlight-styling-003.tentative.html
new file mode 100644
index 0000000000..70d3dc63e5
--- /dev/null
+++ b/testing/web-platform/tests/css/css-pseudo/highlight-styling-003.tentative.html
@@ -0,0 +1,25 @@
+<!doctype html>
+<meta charset="utf-8">
+<title>CSS Pseudo-Elements Test: highlight styling: compat stroke/fill properties</title>
+<link rel="author" title="Delan Azabani" href="mailto:dazabani@igalia.com">
+<link rel="help" href="https://drafts.csswg.org/css-pseudo-4/#highlight-styling">
+<link rel="help" href="https://compat.spec.whatwg.org/#text-fill-and-stroking">
+<link rel="match" href="highlight-styling-003-ref.html">
+<meta name="assert" value="This test verifies that the compat stroke/fill properties are applicable to ::selection.">
+<script src="support/selections.js"></script>
+<link rel="stylesheet" href="support/highlights.css">
+<style>
+ main {
+ font-size: 7em;
+ margin: 0.5em;
+ }
+ main::selection {
+ color: white;
+ -webkit-text-fill-color: yellow;
+ -webkit-text-stroke-color: green;
+ -webkit-text-stroke-width: 4px;
+ }
+</style>
+<p>Test passes if the text below is yellow with a green outline.
+<main class="highlight_reftest">quick</main>
+<script>selectNodeContents(document.querySelector("main"));</script>