summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/dom/nodes/Element-setAttribute.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /testing/web-platform/tests/dom/nodes/Element-setAttribute.html
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/dom/nodes/Element-setAttribute.html')
-rw-r--r--testing/web-platform/tests/dom/nodes/Element-setAttribute.html38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/web-platform/tests/dom/nodes/Element-setAttribute.html b/testing/web-platform/tests/dom/nodes/Element-setAttribute.html
new file mode 100644
index 0000000000..7609406815
--- /dev/null
+++ b/testing/web-platform/tests/dom/nodes/Element-setAttribute.html
@@ -0,0 +1,38 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<title>Element.prototype.setAttribute</title>
+<link rel=help href="https://dom.spec.whatwg.org/#dom-element-setattribute">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+
+<script>
+"use strict";
+
+test(() => {
+
+ const el = document.createElement("p");
+ el.setAttributeNS("foo", "x", "first");
+ el.setAttributeNS("foo2", "x", "second");
+
+ el.setAttribute("x", "changed");
+
+ assert_equals(el.attributes.length, 2);
+ assert_equals(el.getAttribute("x"), "changed");
+ assert_equals(el.getAttributeNS("foo", "x"), "changed");
+ assert_equals(el.getAttributeNS("foo2", "x"), "second");
+
+}, "setAttribute should change the first attribute, irrespective of namespace");
+
+test(() => {
+ // https://github.com/whatwg/dom/issues/31
+
+ const el = document.createElement("p");
+ el.setAttribute("FOO", "bar");
+
+ assert_equals(el.getAttribute("foo"), "bar");
+ assert_equals(el.getAttribute("FOO"), "bar");
+ assert_equals(el.getAttributeNS("", "foo"), "bar");
+ assert_equals(el.getAttributeNS("", "FOO"), null);
+
+}, "setAttribute should lowercase before setting");
+</script>