summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/links/manifest/link-relationship
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /testing/web-platform/tests/html/links/manifest/link-relationship
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/html/links/manifest/link-relationship')
-rw-r--r--testing/web-platform/tests/html/links/manifest/link-relationship/link-rel-manifest.html16
-rw-r--r--testing/web-platform/tests/html/links/manifest/link-relationship/link-tree-order-manual.html13
2 files changed, 29 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/links/manifest/link-relationship/link-rel-manifest.html b/testing/web-platform/tests/html/links/manifest/link-relationship/link-rel-manifest.html
new file mode 100644
index 0000000000..2d9fd78948
--- /dev/null
+++ b/testing/web-platform/tests/html/links/manifest/link-relationship/link-rel-manifest.html
@@ -0,0 +1,16 @@
+<!DOCTYPE html>
+<title>
+ Test that "manifest" is a supported value for the `rel` of a `link`
+</title>
+<link rel="help" href="https://html.spec.whatwg.org/#link-type-manifest" />
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script>
+ test(() => {
+ const result = document.createElement("link").relList.supports("manifest");
+ assert_true(
+ result,
+ "Expected true if manifest is supported as a link relationship"
+ );
+ }, 'link element supports a rel value of "manifest".');
+</script>
diff --git a/testing/web-platform/tests/html/links/manifest/link-relationship/link-tree-order-manual.html b/testing/web-platform/tests/html/links/manifest/link-relationship/link-tree-order-manual.html
new file mode 100644
index 0000000000..aa9ec9c12d
--- /dev/null
+++ b/testing/web-platform/tests/html/links/manifest/link-relationship/link-tree-order-manual.html
@@ -0,0 +1,13 @@
+<!DOCTYPE html>
+<title>Test that name member is supported</title>
+<link rel="help" href="https://html.spec.whatwg.org/#link-type-manifest" />
+<link rel="manifesto" href="/appmanifest/name-member/name-member-fail.webmanifest" />
+<link
+ rel="hello manifest another-relationship"
+ href="/appmanifest/name-member/name-member.webmanifest"
+/>
+<link rel="manifest" href="/appmanifest/name-member/name-member-fail.webmanifest" />
+<link rel="hello manifest" href="/appmanifest/name-member/name-member-fail.webmanifest" />
+<p>
+ If when installing the name is "pass" then the test has passed.
+</p>