summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html')
-rw-r--r--testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html12
1 files changed, 12 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html b/testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html
new file mode 100644
index 0000000000..3d1eaf02a2
--- /dev/null
+++ b/testing/web-platform/tests/html/syntax/parsing/quotes-in-meta.html
@@ -0,0 +1,12 @@
+<!doctype html>
+<meta http-equiv="Content-Type" content='charset="windows-1251'>
+<meta charset=windows-1250>
+<title></title>
+<script src=/resources/testharness.js></script>
+<script src=/resources/testharnessreport.js></script>
+<link rel=help href="https://html.spec.whatwg.org/#algorithm-for-extracting-a-character-encoding-from-a-meta-element">
+<script>
+test(function() {
+ assert_equals(document.characterSet, "windows-1250");
+});
+</script>