summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/shadow-dom/directionality-001.tentative.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /testing/web-platform/tests/shadow-dom/directionality-001.tentative.html
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/shadow-dom/directionality-001.tentative.html')
-rw-r--r--testing/web-platform/tests/shadow-dom/directionality-001.tentative.html19
1 files changed, 19 insertions, 0 deletions
diff --git a/testing/web-platform/tests/shadow-dom/directionality-001.tentative.html b/testing/web-platform/tests/shadow-dom/directionality-001.tentative.html
new file mode 100644
index 0000000000..d96926ad65
--- /dev/null
+++ b/testing/web-platform/tests/shadow-dom/directionality-001.tentative.html
@@ -0,0 +1,19 @@
+<!doctype html>
+<title>Test: directionality propagation in Shadow DOM.</title>
+<link rel="author" href="mailto:emilio@crisal.io" title="Emilio Cobos Álvarez">
+<link rel="help" href="https://html.spec.whatwg.org/#the-dir-attribute">
+<link rel="help" href="https://github.com/whatwg/html/issues/3699">
+<link rel="match" href="directionality-001-ref.html">
+<div id="host0" dir="rtl"><span> 789 101112 </span></div>
+<div id="host1" dir="rtl"><span> 789 101112 </span></div>
+<div id="host2" dir="rtl"><span> 789 101112 </span></div>
+<script>
+ host0.attachShadow({mode: 'closed'}).innerHTML =
+ '<div> 123 456 <span><slot></slot></span></div>';
+
+ host1.attachShadow({mode: 'closed'}).innerHTML =
+ '<div> 123 456 <span dir="ltr"><slot></slot></span></div>';
+
+ host2.attachShadow({mode: 'closed'}).innerHTML =
+ '<div> 123 456 <span><slot dir="ltr"></slot></span></div>';
+</script>