summaryrefslogtreecommitdiffstats
path: root/third_party/jpeg-xl/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/jpeg-xl/debian/rules
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/jpeg-xl/debian/rules')
-rwxr-xr-xthird_party/jpeg-xl/debian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/third_party/jpeg-xl/debian/rules b/third_party/jpeg-xl/debian/rules
new file mode 100755
index 0000000000..04a9f0b68d
--- /dev/null
+++ b/third_party/jpeg-xl/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/pkg-info.mk
+
+%:
+ dh $@ --buildsystem=cmake
+
+override_dh_auto_configure:
+ # TODO(deymo): Remove the DCMAKE_BUILD_TYPE once builds without NDEBUG
+ # are as useful as Release builds.
+ dh_auto_configure -- \
+ -DJPEGXL_VERSION=$(DEB_VERSION) \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DJPEGXL_FORCE_SYSTEM_GTEST=ON \
+ -DJPEGXL_FORCE_SYSTEM_BROTLI=ON \
+ -DJPEGXL_FORCE_SYSTEM_HWY=ON \
+ -DJPEGXL_ENABLE_JPEGLI_LIBJPEG=OFF \
+ -DJPEGXL_ENABLE_PLUGINS=ON