summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cargo_metadata/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/cargo_metadata/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cargo_metadata/Cargo.toml')
-rw-r--r--third_party/rust/cargo_metadata/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/third_party/rust/cargo_metadata/Cargo.toml b/third_party/rust/cargo_metadata/Cargo.toml
new file mode 100644
index 0000000000..cbb937e85a
--- /dev/null
+++ b/third_party/rust/cargo_metadata/Cargo.toml
@@ -0,0 +1,49 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "cargo_metadata"
+version = "0.14.2"
+authors = ["Oliver Schneider <git-spam-no-reply9815368754983@oli-obk.de>"]
+description = "structured access to the output of `cargo metadata`"
+readme = "README.md"
+license = "MIT"
+repository = "https://github.com/oli-obk/cargo_metadata"
+[package.metadata.cargo_metadata_test]
+other_field = "foo"
+some_field = true
+[dependencies.camino]
+version = "1.0.1"
+features = ["serde1"]
+
+[dependencies.cargo-platform]
+version = "0.1"
+
+[dependencies.derive_builder]
+version = "0.9.0"
+optional = true
+
+[dependencies.semver]
+version = "1"
+features = ["serde"]
+
+[dependencies.serde]
+version = "1.0.107"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0.59"
+features = ["unbounded_depth"]
+
+[features]
+builder = ["derive_builder"]
+default = []