summaryrefslogtreecommitdiffstats
path: root/third_party/rust/coreaudio-sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/coreaudio-sys/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/coreaudio-sys/Cargo.toml')
-rw-r--r--third_party/rust/coreaudio-sys/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/coreaudio-sys/Cargo.toml b/third_party/rust/coreaudio-sys/Cargo.toml
new file mode 100644
index 0000000000..bd06fe102f
--- /dev/null
+++ b/third_party/rust/coreaudio-sys/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "coreaudio-sys"
+version = "0.2.11"
+authors = ["Mitchell Nordine <mitchell.nordine@gmail.com>"]
+build = "build.rs"
+description = "Bindings for Apple's CoreAudio frameworks generated via rust-bindgen"
+homepage = "https://github.com/RustAudio/coreaudio-sys"
+readme = "README.md"
+keywords = [
+ "core",
+ "audio",
+ "unit",
+ "osx",
+ "ios",
+]
+license = "MIT"
+repository = "https://github.com/RustAudio/coreaudio-sys.git"
+
+[package.metadata.docs.rs]
+all-features = true
+default-target = "x86_64-apple-darwin"
+targets = [
+ "x86_64-apple-darwin",
+ "x86_64-apple-ios",
+]
+
+[build-dependencies.bindgen]
+version = "0.61"
+features = ["runtime"]
+default-features = false
+
+[features]
+audio_toolbox = []
+audio_unit = []
+core_audio = []
+core_midi = []
+default = [
+ "audio_toolbox",
+ "audio_unit",
+ "core_audio",
+ "open_al",
+ "core_midi",
+]
+open_al = []