summaryrefslogtreecommitdiffstats
path: root/third_party/rust/crypto-common/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/crypto-common/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/crypto-common/Cargo.toml')
-rw-r--r--third_party/rust/crypto-common/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/third_party/rust/crypto-common/Cargo.toml b/third_party/rust/crypto-common/Cargo.toml
new file mode 100644
index 0000000000..cfac76fa97
--- /dev/null
+++ b/third_party/rust/crypto-common/Cargo.toml
@@ -0,0 +1,51 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "crypto-common"
+version = "0.1.6"
+authors = ["RustCrypto Developers"]
+description = "Common cryptographic traits"
+documentation = "https://docs.rs/crypto-common"
+readme = "README.md"
+keywords = [
+ "crypto",
+ "traits",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/traits"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.generic-array]
+version = "0.14.4"
+features = ["more_lengths"]
+
+[dependencies.rand_core]
+version = "0.6"
+optional = true
+
+[dependencies.typenum]
+version = "1.14"
+
+[features]
+getrandom = ["rand_core/getrandom"]
+std = []