summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cubeb-pulse/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/cubeb-pulse/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cubeb-pulse/Cargo.toml')
-rw-r--r--third_party/rust/cubeb-pulse/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/third_party/rust/cubeb-pulse/Cargo.toml b/third_party/rust/cubeb-pulse/Cargo.toml
new file mode 100644
index 0000000000..0aecba5b38
--- /dev/null
+++ b/third_party/rust/cubeb-pulse/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "cubeb-pulse"
+version = "0.4.1"
+authors = ["Dan Glastonbury <dglastonbury@mozilla.com>"]
+description = "Cubeb backed for PulseAudio written in Rust"
+license = "ISC"
+
+[features]
+pulse-dlopen = ["pulse-ffi/dlopen"]
+
+[lib]
+crate-type = ["staticlib", "rlib"]
+
+[dependencies]
+cubeb-backend = "0.10.3"
+pulse-ffi = { path = "pulse-ffi" }
+pulse = { path = "pulse-rs" }
+semver = "1.0"
+ringbuf = "0.2"