summaryrefslogtreecommitdiffstats
path: root/third_party/rust/dashmap/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/dashmap/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/dashmap/Cargo.toml')
-rw-r--r--third_party/rust/dashmap/Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/third_party/rust/dashmap/Cargo.toml b/third_party/rust/dashmap/Cargo.toml
new file mode 100644
index 0000000000..4b309ef8d5
--- /dev/null
+++ b/third_party/rust/dashmap/Cargo.toml
@@ -0,0 +1,45 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "dashmap"
+version = "4.0.2"
+authors = ["Acrimon <joel.wejdenstal@gmail.com>"]
+description = "Blazing fast concurrent HashMap for Rust."
+homepage = "https://github.com/xacrimon/dashmap"
+documentation = "https://docs.rs/dashmap"
+readme = "README.md"
+keywords = ["atomic", "concurrent", "hashmap"]
+categories = ["concurrency", "algorithms", "data-structures"]
+license = "MIT"
+repository = "https://github.com/xacrimon/dashmap"
+[package.metadata.docs.rs]
+features = ["rayon", "raw-api", "serde"]
+[dependencies.cfg-if]
+version = "1.0.0"
+
+[dependencies.num_cpus]
+version = "1.13.0"
+
+[dependencies.rayon]
+version = "1.5.0"
+optional = true
+
+[dependencies.serde]
+version = "1.0.118"
+features = ["derive"]
+optional = true
+
+[features]
+default = []
+raw-api = []