summaryrefslogtreecommitdiffstats
path: root/third_party/rust/futures-0.1.31/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/futures-0.1.31/README.md
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/futures-0.1.31/README.md')
-rw-r--r--third_party/rust/futures-0.1.31/README.md59
1 files changed, 59 insertions, 0 deletions
diff --git a/third_party/rust/futures-0.1.31/README.md b/third_party/rust/futures-0.1.31/README.md
new file mode 100644
index 0000000000..1c33d5ddbb
--- /dev/null
+++ b/third_party/rust/futures-0.1.31/README.md
@@ -0,0 +1,59 @@
+# futures-rs
+
+This library is an implementation of **zero-cost futures** in Rust.
+
+[![Build Status](https://img.shields.io/github/workflow/status/rust-lang/futures-rs/CI/master)](https://github.com/rust-lang/futures-rs/actions)
+[![Crates.io](https://img.shields.io/crates/v/futures.svg?maxAge=2592000)](https://crates.io/crates/futures)
+
+[Documentation](https://docs.rs/futures)
+
+[Tutorial](https://tokio.rs/docs/getting-started/futures/)
+
+## Usage
+
+First, add this to your `Cargo.toml`:
+
+```toml
+[dependencies]
+futures = "0.1.26"
+```
+
+Next, add this to your crate:
+
+```rust
+extern crate futures;
+
+use futures::Future;
+```
+
+For more information about how you can use futures with async I/O you can take a
+look at [https://tokio.rs](https://tokio.rs) which is an introduction to both
+the Tokio stack and also futures.
+
+### Feature `use_std`
+
+`futures-rs` works without the standard library, such as in bare metal environments.
+However, it has a significantly reduced API surface. To use `futures-rs` in
+a `#[no_std]` environment, use:
+
+```toml
+[dependencies]
+futures = { version = "0.1.26", default-features = false }
+```
+
+# License
+
+This project is licensed under either of
+
+ * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or
+ http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or
+ http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in Futures by you, as defined in the Apache-2.0 license, shall be
+dual licensed as above, without any additional terms or conditions.