summaryrefslogtreecommitdiffstats
path: root/third_party/rust/mapped_hyph/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/mapped_hyph/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/mapped_hyph/Cargo.toml')
-rw-r--r--third_party/rust/mapped_hyph/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/third_party/rust/mapped_hyph/Cargo.toml b/third_party/rust/mapped_hyph/Cargo.toml
new file mode 100644
index 0000000000..2c2d762079
--- /dev/null
+++ b/third_party/rust/mapped_hyph/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "mapped_hyph"
+description = "Hyphenation using precompiled memory-mapped tables"
+version = "0.4.3"
+authors = ["Jonathan Kew <jfkthame@gmail.com>"]
+license = "MIT/Apache-2.0"
+edition = "2018"
+
+[dependencies]
+memmap2 = { version = ">=0.2,<=0.5" }
+arrayref = "0.3.5"
+log = "0.4"
+
+[dev-dependencies]
+criterion = "0.3"
+
+[[bench]]
+name = "bench"
+harness = false