summaryrefslogtreecommitdiffstats
path: root/third_party/rust/memoffset-0.5.6/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/memoffset-0.5.6/README.md
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/memoffset-0.5.6/README.md')
-rw-r--r--third_party/rust/memoffset-0.5.6/README.md79
1 files changed, 79 insertions, 0 deletions
diff --git a/third_party/rust/memoffset-0.5.6/README.md b/third_party/rust/memoffset-0.5.6/README.md
new file mode 100644
index 0000000000..b035674f90
--- /dev/null
+++ b/third_party/rust/memoffset-0.5.6/README.md
@@ -0,0 +1,79 @@
+# memoffset #
+
+[![](http://meritbadge.herokuapp.com/memoffset)](https://crates.io/crates/memoffset)
+
+C-Like `offset_of` functionality for Rust structs.
+
+Introduces the following macros:
+ * `offset_of!` for obtaining the offset of a member of a struct.
+ * `span_of!` for obtaining the range that a field, or fields, span.
+
+`memoffset` works under `no_std` environments.
+
+## Usage ##
+Add the following dependency to your `Cargo.toml`:
+
+```toml
+[dependencies]
+memoffset = "0.5"
+```
+
+These versions will compile fine with rustc versions greater or equal to 1.19.
+
+Add the following lines at the top of your `main.rs` or `lib.rs` files.
+
+```rust,ignore
+#[macro_use]
+extern crate memoffset;
+```
+
+## Examples ##
+```rust
+#[macro_use]
+extern crate memoffset;
+
+#[repr(C, packed)]
+struct Foo {
+ a: u32,
+ b: u32,
+ c: [u8; 5],
+ d: u32,
+}
+
+fn main() {
+ assert_eq!(offset_of!(Foo, b), 4);
+ assert_eq!(offset_of!(Foo, d), 4+4+5);
+
+ assert_eq!(span_of!(Foo, a), 0..4);
+ assert_eq!(span_of!(Foo, a .. c), 0..8);
+ assert_eq!(span_of!(Foo, a ..= c), 0..13);
+ assert_eq!(span_of!(Foo, ..= d), 0..17);
+ assert_eq!(span_of!(Foo, b ..), 4..17);
+}
+```
+
+## Feature flags ##
+
+### Usage in constants ###
+`memoffset` has **experimental** support for compile-time `offset_of!` on a nightly compiler.
+
+In order to use it, you must enable the `unstable_const` crate feature and several compiler features.
+
+Cargo.toml:
+```toml
+[dependencies.memoffset]
+version = "0.5"
+features = ["unstable_const"]
+```
+
+Your crate root: (`lib.rs`/`main.rs`)
+```rust,ignore
+#![feature(ptr_offset_from, const_ptr_offset_from, const_maybe_uninit_as_ptr, const_raw_ptr_deref)]
+```
+
+If you intend to use `offset_of!` inside a `const fn`, also add the `const_fn` compiler feature.
+
+### Raw references ###
+Recent nightlies support [a way to create raw pointers](https://github.com/rust-lang/rust/issues/73394) that avoids creating intermediate safe references.
+`memoffset` can make use of that feature to avoid what is technically Undefined Behavior.
+Use the `unstable_raw` feature to enable this.