summaryrefslogtreecommitdiffstats
path: root/third_party/rust/midir/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/midir/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/midir/Cargo.toml')
-rw-r--r--third_party/rust/midir/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/third_party/rust/midir/Cargo.toml b/third_party/rust/midir/Cargo.toml
new file mode 100644
index 0000000000..177b095493
--- /dev/null
+++ b/third_party/rust/midir/Cargo.toml
@@ -0,0 +1,59 @@
+[workspace]
+members = [
+ ".",
+ "examples/browser",
+]
+
+[package]
+name = "midir"
+version = "0.7.0"
+authors = ["Patrick Reisert"]
+description = "A cross-platform, realtime MIDI processing library, inspired by RtMidi."
+repository = "https://github.com/Boddlnagg/midir"
+readme = "README.md"
+keywords = ["midi", "audio", "music", "sound"]
+categories = ["multimedia::audio", "api-bindings"]
+license = "MIT"
+
+[features]
+default = []
+avoid_timestamping = []
+jack = ["jack-sys", "libc"]
+
+[dependencies]
+bitflags = "1.2"
+memalloc = "0.1.0"
+jack-sys = { version = "0.1.0", optional = true }
+libc = { version = "0.2.21", optional = true }
+winrt = { version = "0.7.0", optional = true}
+
+[target.'cfg(target_os = "linux")'.dependencies]
+alsa = "0.7"
+libc = "0.2.21"
+
+[target.'cfg(target_os = "macos")'.dependencies]
+coremidi = "0.6.0"
+
+[target.'cfg(windows)'.dependencies]
+winapi = { version = "0.3", features = ["mmsystem", "mmeapi"] }
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+js-sys = "0.3"
+wasm-bindgen = "0.2"
+web-sys = { version = "0.3", features = [
+ "Event",
+ "Navigator",
+ "Window",
+ "MidiAccess",
+ "MidiInput",
+ "MidiInputMap",
+ "MidiMessageEvent",
+ "MidiOptions",
+ "MidiOutput",
+ "MidiOutputMap",
+ "MidiPort",
+ "MidiPortType"
+]}
+
+[target.'cfg(target_arch = "wasm32")'.dev-dependencies]
+wasm-bindgen-test = "0.2"