summaryrefslogtreecommitdiffstats
path: root/third_party/rust/peeking_take_while/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/peeking_take_while/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/peeking_take_while/Cargo.toml')
-rw-r--r--third_party/rust/peeking_take_while/Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/third_party/rust/peeking_take_while/Cargo.toml b/third_party/rust/peeking_take_while/Cargo.toml
new file mode 100644
index 0000000000..40aeef2d79
--- /dev/null
+++ b/third_party/rust/peeking_take_while/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+authors = ["Nick Fitzgerald <fitzgen@gmail.com>"]
+description = "Like `Iterator::take_while`, but calls the predicate on a peeked value. This allows you to use `Iterator::by_ref` and `Iterator::take_while` together, and still get the first value for which the `take_while` predicate returned false after dropping the `by_ref`."
+categories = ["rust-patterns"]
+keywords = ["iterator", "take_while", "peek", "by_ref"]
+license = "Apache-2.0/MIT"
+name = "peeking_take_while"
+readme = "./README.md"
+repository = "https://github.com/fitzgen/peeking_take_while"
+version = "0.1.2"
+
+[badges]
+[badges.travis-ci]
+repository = "fitzgen/peeking_take_while"