summaryrefslogtreecommitdiffstats
path: root/third_party/rust/serial_test_derive/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/serial_test_derive/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/serial_test_derive/Cargo.toml')
-rw-r--r--third_party/rust/serial_test_derive/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/third_party/rust/serial_test_derive/Cargo.toml b/third_party/rust/serial_test_derive/Cargo.toml
new file mode 100644
index 0000000000..95fe5bcfe9
--- /dev/null
+++ b/third_party/rust/serial_test_derive/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "serial_test_derive"
+version = "0.6.0"
+authors = ["Tom Parker-Shemilt <palfrey@tevp.net>"]
+description = "Helper crate for serial_test"
+readme = "README.md"
+categories = ["development-tools::testing"]
+license = "MIT"
+repository = "https://github.com/palfrey/serial_test/"
+
+[lib]
+proc-macro = true
+[dependencies.proc-macro-error]
+version = "1"
+
+[dependencies.proc-macro2]
+version = "1.0"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.rustversion]
+version = "1.0"
+
+[dependencies.syn]
+version = "1.0"
+features = ["full"]
+[dev-dependencies.env_logger]
+version = ">= 0.7, <0.9"
+
+[dev-dependencies.trybuild]
+version = "1"