summaryrefslogtreecommitdiffstats
path: root/third_party/rust/sfv/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/sfv/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/sfv/Cargo.toml')
-rw-r--r--third_party/rust/sfv/Cargo.toml60
1 files changed, 60 insertions, 0 deletions
diff --git a/third_party/rust/sfv/Cargo.toml b/third_party/rust/sfv/Cargo.toml
new file mode 100644
index 0000000000..1827d69d5d
--- /dev/null
+++ b/third_party/rust/sfv/Cargo.toml
@@ -0,0 +1,60 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "sfv"
+version = "0.9.3"
+authors = ["Tania Batieva <yalyna.ts@gmail.com>"]
+exclude = [
+ "tests/**",
+ ".github/*",
+]
+description = """
+Structured Field Values for HTTP parser.
+Implementation of RFC 8941."""
+documentation = "https://docs.rs/sfv"
+readme = "README.md"
+keywords = [
+ "http-header",
+ "structured-header",
+]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/undef1nd/sfv"
+
+[[bench]]
+name = "bench"
+harness = false
+
+[dependencies.data-encoding]
+version = "2.3.2"
+
+[dependencies.indexmap]
+version = "1.8.0"
+
+[dependencies.rust_decimal]
+version = "1.20.0"
+default-features = false
+
+[dev-dependencies.criterion]
+version = "0.4.0"
+
+[dev-dependencies.rust_decimal]
+version = "1.20.0"
+features = ["std"]
+default-features = false
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0"