summaryrefslogtreecommitdiffstats
path: root/third_party/rust/terminal_size/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/terminal_size/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/terminal_size/Cargo.toml')
-rw-r--r--third_party/rust/terminal_size/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/third_party/rust/terminal_size/Cargo.toml b/third_party/rust/terminal_size/Cargo.toml
new file mode 100644
index 0000000000..d8921879d5
--- /dev/null
+++ b/third_party/rust/terminal_size/Cargo.toml
@@ -0,0 +1,27 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "terminal_size"
+version = "0.1.17"
+authors = ["Andrew Chin <achin@eminence32.net>"]
+description = "Gets the size of your Linux or Windows terminal"
+documentation = "http://eminence.github.io/terminal-size/doc/terminal_size/index.html"
+keywords = ["terminal", "console", "term", "size", "dimensions"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/eminence/terminal-size"
+[target."cfg(not(windows))".dependencies.libc]
+version = "0.2"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["handleapi", "processenv", "winbase", "wincon", "winnt"]