summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tokio-stream/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /third_party/rust/tokio-stream/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-43a97878ce14b72f0981164f87f2e35e14151312.tar.xz
firefox-43a97878ce14b72f0981164f87f2e35e14151312.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/tokio-stream/Cargo.toml')
-rw-r--r--third_party/rust/tokio-stream/Cargo.toml81
1 files changed, 81 insertions, 0 deletions
diff --git a/third_party/rust/tokio-stream/Cargo.toml b/third_party/rust/tokio-stream/Cargo.toml
new file mode 100644
index 0000000000..df1dc53431
--- /dev/null
+++ b/third_party/rust/tokio-stream/Cargo.toml
@@ -0,0 +1,81 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.49"
+name = "tokio-stream"
+version = "0.1.11"
+authors = ["Tokio Contributors <team@tokio.rs>"]
+description = """
+Utilities to work with `Stream` and `tokio`.
+"""
+homepage = "https://tokio.rs"
+categories = ["asynchronous"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tokio"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+rustc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.futures-core]
+version = "0.3.0"
+
+[dependencies.pin-project-lite]
+version = "0.2.0"
+
+[dependencies.tokio]
+version = "1.8.0"
+features = ["sync"]
+
+[dependencies.tokio-util]
+version = "0.7.0"
+optional = true
+
+[dev-dependencies.async-stream]
+version = "0.3"
+
+[dev-dependencies.futures]
+version = "0.3"
+default-features = false
+
+[dev-dependencies.parking_lot]
+version = "0.12.0"
+
+[dev-dependencies.tokio]
+version = "1.2.0"
+features = [
+ "full",
+ "test-util",
+]
+
+[features]
+default = ["time"]
+fs = ["tokio/fs"]
+io-util = ["tokio/io-util"]
+net = ["tokio/net"]
+signal = ["tokio/signal"]
+sync = [
+ "tokio/sync",
+ "tokio-util",
+]
+time = ["tokio/time"]
+
+[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies.proptest]
+version = "1"