summaryrefslogtreecommitdiffstats
path: root/toolkit/components/glean/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:22:09 +0000
commit43a97878ce14b72f0981164f87f2e35e14151312 (patch)
tree620249daf56c0258faa40cbdcf9cfba06de2a846 /toolkit/components/glean/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 110.0.1.upstream/110.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/components/glean/Cargo.toml')
-rw-r--r--toolkit/components/glean/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/toolkit/components/glean/Cargo.toml b/toolkit/components/glean/Cargo.toml
new file mode 100644
index 0000000000..2bf4a745e0
--- /dev/null
+++ b/toolkit/components/glean/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "fog_control"
+version = "0.1.0"
+authors = ["Glean SDK team <glean-team@mozilla.com>"]
+edition = "2018"
+license = "MPL-2.0"
+
+[dependencies]
+glean = "51.8.2"
+log = "0.4"
+nserror = { path = "../../../xpcom/rust/nserror" }
+nsstring = { path = "../../../xpcom/rust/nsstring" }
+static_prefs = { path = "../../../modules/libpref/init/static_prefs" }
+xpcom = { path = "../../../xpcom/rust/xpcom" }
+once_cell = "1.2.0"
+fog = { path = "./api" }
+cstr = "0.2"
+viaduct = "0.1"
+url = "2.1"
+thin-vec = { version = "0.2.1", features = ["gecko-ffi"] }
+
+[features]
+# Leave data collection enabled, but disable upload.
+disable_upload = []
+# Letting us know we're compiling with Gecko symbols.
+with_gecko = ["fog/with_gecko"]
+# Opt into a larger preinit queue
+million_queue = ["glean/preinit_million_queue"]