summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/css-sizing/aspect-ratio/flex-aspect-ratio-030.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/css-sizing/aspect-ratio/flex-aspect-ratio-030.html')
-rw-r--r--testing/web-platform/tests/css/css-sizing/aspect-ratio/flex-aspect-ratio-030.html21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/css-sizing/aspect-ratio/flex-aspect-ratio-030.html b/testing/web-platform/tests/css/css-sizing/aspect-ratio/flex-aspect-ratio-030.html
new file mode 100644
index 0000000000..df6d6985c5
--- /dev/null
+++ b/testing/web-platform/tests/css/css-sizing/aspect-ratio/flex-aspect-ratio-030.html
@@ -0,0 +1,21 @@
+<!DOCTYPE html>
+<title>CSS aspect-ratio: auto height img with specified width and attributes width / height inside column flexbox</title>
+<link rel="help" href="https://html.spec.whatwg.org/#map-to-the-aspect-ratio-property-(using-dimension-rules)">
+<link rel="help" href="https://www.w3.org/TR/css-flexbox-1/#layout-algorithm">
+<link rel="match" href="../../reference/ref-filled-green-100px-square.xht" />
+
+<p>Test passes if there is a filled green square and <strong>no red</strong>.</p>
+<style>
+ div {
+ display: flex;
+ }
+ img {
+ width: 100px;
+ height: auto;
+ }
+</style>
+</head>
+<body>
+ <div><img src="support/200x200-green.png" width="200" height="200"></div>
+</body>
+</html>