summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/dom/nodes/MutationObserver-callback-arguments.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/dom/nodes/MutationObserver-callback-arguments.html')
-rw-r--r--testing/web-platform/tests/dom/nodes/MutationObserver-callback-arguments.html31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/web-platform/tests/dom/nodes/MutationObserver-callback-arguments.html b/testing/web-platform/tests/dom/nodes/MutationObserver-callback-arguments.html
new file mode 100644
index 0000000000..d64758cb4f
--- /dev/null
+++ b/testing/web-platform/tests/dom/nodes/MutationObserver-callback-arguments.html
@@ -0,0 +1,31 @@
+<!DOCTYPE HTML>
+<meta charset=utf-8>
+<title>MutationObserver: callback arguments</title>
+<link rel="help" href="https://dom.spec.whatwg.org/#notify-mutation-observers">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<div id="mo-target"></div>
+<div id="log"></div>
+<script>
+"use strict";
+
+async_test(t => {
+ const moTarget = document.querySelector("#mo-target");
+ const mo = new MutationObserver(function(records, observer) {
+ t.step(() => {
+ assert_equals(this, mo);
+ assert_equals(arguments.length, 2);
+ assert_true(Array.isArray(records));
+ assert_equals(records.length, 1);
+ assert_true(records[0] instanceof MutationRecord);
+ assert_equals(observer, mo);
+
+ mo.disconnect();
+ t.done();
+ });
+ });
+
+ mo.observe(moTarget, {attributes: true});
+ moTarget.className = "trigger-mutation";
+}, "Callback is invoked with |this| value of MutationObserver and two arguments");
+</script>