summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/dom/nodes/getElementsByClassName-14.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/dom/nodes/getElementsByClassName-14.htm')
-rw-r--r--testing/web-platform/tests/dom/nodes/getElementsByClassName-14.htm26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/web-platform/tests/dom/nodes/getElementsByClassName-14.htm b/testing/web-platform/tests/dom/nodes/getElementsByClassName-14.htm
new file mode 100644
index 0000000000..83addb7ba5
--- /dev/null
+++ b/testing/web-platform/tests/dom/nodes/getElementsByClassName-14.htm
@@ -0,0 +1,26 @@
+<!-- quirks mode -->
+<html class="a A">
+ <head>
+ <title>document.getElementsByClassName(): case-insensitive (quirks mode)</title>
+ <link rel="help" href="https://dom.spec.whatwg.org/#concept-getelementsbyclassname">
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ </head>
+ <body class="a a">
+ <div id="log"></div>
+ <div class="k"></div>
+ <div class="K"></div>
+ <div class="&#x212a;" id="kelvin"></div>
+ <script>
+test(function() {
+ assert_array_equals(document.getElementsByClassName("A a"),
+ [document.documentElement, document.body]);
+})
+
+test(function() {
+ assert_array_equals(document.getElementsByClassName("\u212a"),
+ [document.getElementById("kelvin")]);
+}, 'Unicode-case should be sensitive even in quirks mode.');
+ </script>
+ </body>
+</html>