summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/webidl/ecmascript-binding/default-toJSON-cross-realm.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/webidl/ecmascript-binding/default-toJSON-cross-realm.html')
-rw-r--r--testing/web-platform/tests/webidl/ecmascript-binding/default-toJSON-cross-realm.html26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/web-platform/tests/webidl/ecmascript-binding/default-toJSON-cross-realm.html b/testing/web-platform/tests/webidl/ecmascript-binding/default-toJSON-cross-realm.html
new file mode 100644
index 0000000000..79c3097f33
--- /dev/null
+++ b/testing/web-platform/tests/webidl/ecmascript-binding/default-toJSON-cross-realm.html
@@ -0,0 +1,26 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<title>Cross-realm [Default] toJSON() creates result object in its realm</title>
+<link rel="help" href="https://webidl.spec.whatwg.org/#default-tojson-steps">
+
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script src="support/create-realm.js"></script>
+
+<body>
+<script>
+promise_test(async t => {
+ const other = await createRealm(t);
+ const json = other.DOMRectReadOnly.prototype.toJSON.call(new DOMRectReadOnly());
+
+ assert_equals(Object.getPrototypeOf(json), other.Object.prototype);
+}, "Cross-realm [Default] toJSON() creates result object in its realm");
+
+promise_test(async t => {
+ const other = await createRealm(t);
+ const json = other.DOMQuad.prototype.toJSON.call(new DOMQuad());
+
+ assert_equals(Object.getPrototypeOf(json.p1), DOMPoint.prototype);
+}, "Cross-realm [Default] toJSON() converts its interface attributes to ECMAScript values of correct realm");
+</script>
+</body>