summaryrefslogtreecommitdiffstats
path: root/third_party/rust/audioipc/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/audioipc/Cargo.toml')
-rw-r--r--third_party/rust/audioipc/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/third_party/rust/audioipc/Cargo.toml b/third_party/rust/audioipc/Cargo.toml
new file mode 100644
index 0000000000..8a9dd3d484
--- /dev/null
+++ b/third_party/rust/audioipc/Cargo.toml
@@ -0,0 +1,49 @@
+[package]
+name = "audioipc"
+version = "0.2.5"
+authors = [
+ "Matthew Gregan <kinetik@flim.org>",
+ "Dan Glastonbury <dan.glastonbury@gmail.com>"
+ ]
+license = "ISC"
+description = "Remote Cubeb IPC"
+edition = "2018"
+
+[dependencies]
+bincode = "1.3"
+bytes = "0.4"
+cubeb = "0.10"
+futures = "0.1.29"
+log = "0.4"
+serde = "1"
+serde_derive = "1"
+tokio = { version="0.1", default-features=false, features = ["rt-full"] }
+tokio-io = "0.1"
+
+[target.'cfg(unix)'.dependencies]
+iovec = "0.1"
+libc = "0.2"
+mio = "0.6.19"
+mio-uds = "0.6.7"
+tokio-reactor = "0.1"
+memmap2 = "0.2"
+
+[target.'cfg(target_os = "linux")'.dependencies.audio_thread_priority]
+version = "0.26.1"
+default-features = false
+
+[target.'cfg(windows)'.dependencies]
+mio = "0.6.19"
+miow = "0.3.3"
+mio-named-pipes = { git = "https://github.com/kinetiknz/mio-named-pipes", rev = "21c26326f5f45f415c49eac4ba5bc41a2f961321" }
+winapi = { version = "0.3.6", features = ["combaseapi", "memoryapi", "objbase"] }
+
+[target.'cfg(target_os = "android")'.dependencies]
+ashmem = "0.1"
+
+[dependencies.error-chain]
+version = "0.12.0"
+default-features = false
+
+[build-dependencies]
+cc = "1.0"