summaryrefslogtreecommitdiffstats
path: root/third_party/rust/crossbeam-deque-0.7.4/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/crossbeam-deque-0.7.4/Cargo.toml')
-rw-r--r--third_party/rust/crossbeam-deque-0.7.4/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/third_party/rust/crossbeam-deque-0.7.4/Cargo.toml b/third_party/rust/crossbeam-deque-0.7.4/Cargo.toml
new file mode 100644
index 0000000000..9e00b37516
--- /dev/null
+++ b/third_party/rust/crossbeam-deque-0.7.4/Cargo.toml
@@ -0,0 +1,33 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "crossbeam-deque"
+version = "0.7.4"
+authors = ["The Crossbeam Project Developers"]
+description = "Concurrent work-stealing deque"
+homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-deque"
+documentation = "https://docs.rs/crossbeam-deque"
+readme = "README.md"
+keywords = ["chase-lev", "lock-free", "scheduler", "scheduling"]
+categories = ["algorithms", "concurrency", "data-structures"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/crossbeam-rs/crossbeam"
+[dependencies.crossbeam-epoch]
+version = "0.8"
+
+[dependencies.crossbeam-utils]
+version = "0.7"
+
+[dependencies.maybe-uninit]
+version = "2.0.0"
+[dev-dependencies.rand]
+version = "0.6"