summaryrefslogtreecommitdiffstats
path: root/third_party/rust/encoding_c/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/encoding_c/Cargo.toml')
-rw-r--r--third_party/rust/encoding_c/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/encoding_c/Cargo.toml b/third_party/rust/encoding_c/Cargo.toml
new file mode 100644
index 0000000000..ee7ecb6acb
--- /dev/null
+++ b/third_party/rust/encoding_c/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "encoding_c"
+version = "0.9.8"
+authors = ["Henri Sivonen <hsivonen@hsivonen.fi>"]
+build = "build.rs"
+links = "encoding_c"
+description = "C API for encoding_rs"
+homepage = "https://docs.rs/encoding_c/"
+documentation = "https://docs.rs/encoding_c/"
+readme = "README.md"
+keywords = ["ffi", "capi", "encoding", "unicode", "charset"]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/hsivonen/encoding_c"
+[dependencies.encoding_rs]
+version = "0.8.20"
+
+[features]
+fast-big5-hanzi-encode = ["encoding_rs/fast-big5-hanzi-encode"]
+fast-gb-hanzi-encode = ["encoding_rs/fast-gb-hanzi-encode"]
+fast-hangul-encode = ["encoding_rs/fast-hangul-encode"]
+fast-hanja-encode = ["encoding_rs/fast-hanja-encode"]
+fast-kanji-encode = ["encoding_rs/fast-kanji-encode"]
+fast-legacy-encode = ["encoding_rs/fast-legacy-encode"]
+less-slow-big5-hanzi-encode = ["encoding_rs/less-slow-big5-hanzi-encode"]
+less-slow-gb-hanzi-encode = ["encoding_rs/less-slow-gb-hanzi-encode"]
+less-slow-kanji-encode = ["encoding_rs/less-slow-kanji-encode"]
+simd-accel = ["encoding_rs/simd-accel"]