summaryrefslogtreecommitdiffstats
path: root/third_party/rust/env_logger/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/env_logger/Cargo.toml')
-rw-r--r--third_party/rust/env_logger/Cargo.toml85
1 files changed, 85 insertions, 0 deletions
diff --git a/third_party/rust/env_logger/Cargo.toml b/third_party/rust/env_logger/Cargo.toml
new file mode 100644
index 0000000000..bf08d9554d
--- /dev/null
+++ b/third_party/rust/env_logger/Cargo.toml
@@ -0,0 +1,85 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "env_logger"
+version = "0.9.3"
+include = [
+ "src/**/*",
+ "tests",
+ "LICENSE-*",
+ "README.md",
+ "CHANGELOG.md",
+]
+description = """
+A logging implementation for `log` which is configured via an environment
+variable.
+"""
+documentation = "https://docs.rs/env_logger"
+readme = "README.md"
+keywords = [
+ "logging",
+ "log",
+ "logger",
+]
+categories = ["development-tools::debugging"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/env-logger-rs/env_logger/"
+
+[[test]]
+name = "regexp_filter"
+harness = false
+
+[[test]]
+name = "log-in-log"
+harness = false
+
+[[test]]
+name = "log_tls_dtors"
+harness = false
+
+[[test]]
+name = "init-twice-retains-filter"
+harness = false
+
+[dependencies.atty]
+version = "0.2.5"
+optional = true
+
+[dependencies.humantime]
+version = "2.0.0"
+optional = true
+
+[dependencies.log]
+version = "0.4.8"
+features = ["std"]
+
+[dependencies.regex]
+version = "1.0.3"
+features = [
+ "std",
+ "perf",
+]
+optional = true
+default-features = false
+
+[dependencies.termcolor]
+version = "1.1.1"
+optional = true
+
+[features]
+default = [
+ "termcolor",
+ "atty",
+ "humantime",
+ "regex",
+]