summaryrefslogtreecommitdiffstats
path: root/third_party/rust/generic-array/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/generic-array/Cargo.toml')
-rw-r--r--third_party/rust/generic-array/Cargo.toml75
1 files changed, 75 insertions, 0 deletions
diff --git a/third_party/rust/generic-array/Cargo.toml b/third_party/rust/generic-array/Cargo.toml
new file mode 100644
index 0000000000..f04fc7bf73
--- /dev/null
+++ b/third_party/rust/generic-array/Cargo.toml
@@ -0,0 +1,75 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "generic-array"
+version = "0.14.6"
+authors = [
+ "Bartłomiej Kamiński <fizyk20@gmail.com>",
+ "Aaron Trent <novacrazy@gmail.com>",
+]
+include = [
+ "src/**/*",
+ "LICENSE",
+ "README.md",
+ "CHANGELOG.md",
+ "build.rs",
+]
+description = "Generic types implementing functionality of arrays"
+documentation = "http://fizyk20.github.io/generic-array/generic_array/"
+readme = "README.md"
+keywords = [
+ "generic",
+ "array",
+]
+categories = [
+ "data-structures",
+ "no-std",
+]
+license = "MIT"
+repository = "https://github.com/fizyk20/generic-array.git"
+
+[package.metadata.docs.rs]
+features = [
+ "serde",
+ "zeroize",
+]
+
+[lib]
+name = "generic_array"
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.typenum]
+version = "1.12"
+
+[dependencies.zeroize]
+version = "1"
+optional = true
+default-features = false
+
+[dev-dependencies.bincode]
+version = "1.0"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[build-dependencies.version_check]
+version = "0.9"
+
+[features]
+more_lengths = []
+
+[badges.travis-ci]
+repository = "fizyk20/generic-array"